Enterprise claims hail damage when there was no hail

  • Hi Guest, welcome to the help forum. You can get fast answers to your customer service questions here. We have a dedicated team of advocates who are ready to help. Just go to the section that matches your question and ask us!
  • If you've posted a question or issue for our advocates to assist with, please be sure to check back frequently for responses and requests for clarification.
  • Did you know you can get email notifications when something new posts to your favorite forum? It's easy. Just click the "watch" link right next to the "post new thread" button at the top of your favorite forum. The rest is easy. Now you'll never miss another conversation.
  • Want to become an expert user? Drop by the How to use this forum section and all will be revealed. We'll show you how to make the most of your experience.
Sep 17, 2019
1
1
1
39
I had my GMC hail damaged and took a rental car from enterprise on Aug 17th. I returned the car in a different location after insurance company informed me that my GMC was totalled. Next day I got a call from enterprise where I dropped the car stating there was hail damage in the car. There was no hail during the 2 days I had the car. Infact the car was parked next to my other car amogst other cars and none of them had any damage. I checked the weather report and it also did not report any damage. But enterprise claims there hail damage on the roof the car and they would be claiming from me and withhold deductible from my credit card. Its been a month now no one has contacted me or made a claim with my insurance. I am 100% sure there was no hail and the weather reports can back me. I am trying to contact them but they keep saying someone from recovery unit will contact me. What can I do in this situation?
 
  • Like
Reactions: Martie Mac